Octopus.com pages (signin/docs/downloads etc.) are returning 404 errors for some users
Incident Report for Octopus Deploy
Postmortem

Postmortem - Read details.

Posted Feb 03, 2023 - 05:26 UTC

Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 15:44 UTC
Monitoring
Our upstream provider has applied a fix that should resolve this issue. We are continuing to monitor this on our side. If you are continuing to see 404 errors navigating to parts of Octopus.com (sign-in, documentation, blog etc.), please contact support@octopus.com
Posted Jan 26, 2023 - 15:07 UTC
Identified
Mitigations didn't hold.
We're back to investigating new options.

Signin / docs and blog are still impacted.
Posted Jan 26, 2023 - 12:38 UTC
Monitoring
**Advice**: go to www.octopus.com (your browser cache will be in your way), and try incognito/private browsing.

We are 302 redirecting from octopus.com to www.octopus.com and are seeing signs of improved availability for impacted systems /signin /docs /blog

Northcentral US may still experience a partial outage depending on how your traffic is routed. Most regions should be healthy or just experience some degraded performance.

The only impact to Octopus Cloud is the log in capabilities.
Posted Jan 26, 2023 - 11:07 UTC
Identified
We have identified a cause of this incident and are working to remediate.
Posted Jan 26, 2023 - 04:19 UTC
Update
We have escalated with our Cloud provider and are working with them to resolve. Further updates will be posted when they are available.
Posted Jan 25, 2023 - 22:59 UTC
Update
We are continuing to investigate and have escalated internally to specialist engineers for additional support. Further updates will be posted when they are available.
Posted Jan 25, 2023 - 21:36 UTC
Update
We currently believe that this is only affecting certain geographical locations and their related CDN endpoints. We are continuing to investigate and have engaged our CDN provider for further assistance/investigation. Further updates will be posted when they are available.
Posted Jan 25, 2023 - 18:32 UTC
Update
We are continuing to investigate this issue
Posted Jan 25, 2023 - 17:22 UTC
Investigating
We are currently investigating this issue.
Posted Jan 25, 2023 - 15:41 UTC
This incident affected: Octopus.com / OctopusId, Octopus Cloud, and Cloud Control Center (billing.octopus.com).