ECS Update steps failing to execute

Incident Report for Octopus Deploy

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 13:10 UTC

Monitoring

We have uploaded a new version of the ECS Update step.

Affected customers can manually force a re-acquisition of the updated packages via the following steps

1. Go to Tasks
2. Click Show Advanced filters
3. Check "Include System Tasks"
4. Select the "Acquire new steps and targets" from the Task Type
5. Choose the most previously run task
6. Select "Re-run" from the context menu (3 dots).
Posted Mar 28, 2025 - 12:02 UTC

Identified

We are aware of an issue where a recent update has caused ECS Update steps to fail deployment.
Posted Mar 28, 2025 - 11:54 UTC