Service connectivity issues due to upstream Azure outage

Incident Report for Octopus Deploy

Resolved

Azure has resolved this issue.
Posted Jul 23, 2026 - 20:28 UTC

Monitoring

Azure's mitigation has allowed access to the impacted services. We will continue to monitor service availability.
Posted Jul 23, 2026 - 18:35 UTC

Update

Known impacted services:
- The Octopus.com blog
Posted Jul 23, 2026 - 16:09 UTC

Identified

Due to upstream Azure issues in the West US region, some services may have no or intermittent connectivity. We are continuing to monitor the impact on our systems.
Posted Jul 23, 2026 - 16:08 UTC
This incident affected: Octopus.com.