Issue identified with Octopus.com and Octopus Cloud Microsoft/AzureAD sign in.
Incident Report for Octopus Deploy
Resolved
We have re-enabled Azure AD login and verified the system is operating as expected. If you used Azure AD to sign into Octopus ID, you may have been logged out as part of this resolution. You should be able to sign in again smoothly, but if you are having issues or have questions, please reach out to our support team.
Posted May 05, 2023 - 05:27 UTC
Monitoring
As promised, we have re-enabled the AzureAD login and are close to marking this as resolved. Do not hesitate to contact us via support if you need help / have questions/hit issues.

We'll monitor for a touch longer to ensure there aren't issues as we're all heading into the weekend. Thank you all for your patience!
Posted May 05, 2023 - 03:41 UTC
Identified
We're ready to move this into "identified" as we had some extended investigation to complete. If all goes well, we can hopefully mark this resolved approx 24 hours from now. If not, we'll keep our wonderful customers updated.

Once again, we thank you for your patience and for using the username and password workaround if impacted by our work on the AzureAD/Microsoft auth flow.
Posted May 04, 2023 - 07:36 UTC
Update
Thanks for your patience.
We're moving forward with changes, but they are taking time as it involves 2+ internal teams coordinating changes.

Please continue using the workaround, and rest assured we will restore the Microsoft/Azure login mechanism as soon as possible.
Posted May 02, 2023 - 13:49 UTC
Investigating
Octopus Deploy is aware of an issue with logging into Octopus.com and Octopus Cloud instances for customers who use Microsoft accounts and AzureAD sign-in.

Our engineers are investigating and we will provide updates.

Workaround: If you use this mechanism to log in, you can fall back to a username (your email) and a new password. You can follow the "forgot password" mechanism to set up a new password.
Posted Apr 29, 2023 - 10:20 UTC
This incident affected: Octopus.com / OctopusId and Octopus Cloud.