Dynamic Worker Leases failing in WestEU
Incident Report for Octopus Deploy
Resolved
Azure has advised that this issue has been resolved. A preliminary root cause has been published here: https://azure.status.microsoft/en-us/status/history/
Posted Jan 21, 2024 - 23:09 UTC
Monitoring
Dynamic Workers are now provisioning successfully. We are continuing to monitor for any degradation of service.
Posted Jan 21, 2024 - 09:17 UTC
Update
We continue to see issues with our upstream. We are investigating a workaround. Another update will be provided within the next hour.
Posted Jan 21, 2024 - 07:31 UTC
Identified
Our upstream provider, Microsoft Azure, is currently experiencing an issue which is affecting our ability to provision worker virtual machines for a subset of customers in WestEU.
See https://azure.status.microsoft/en-gb/status for more details.

If you experience this problem, deployments utilising dynamic workers will fail with an error specifying that Octopus Deploy could not obtain a dynamic worker lease.

We will provide an update in an hour, at approximately 0730 UTC.

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted Jan 21, 2024 - 06:31 UTC
This incident affected: Octopus Cloud.