Some Cloud Instances in West Europe are showing the "Undergoing Maintenance" page
Incident Report for Octopus Deploy
Resolved
The affected Cloud Instances are now operational.
Posted Jan 18, 2023 - 09:37 UTC
Investigating
Some Cloud Instances in the West Europe region are showing the "Octopus Server is Undergoing Maintenance" page. We are currently investigating this issue.
Posted Jan 18, 2023 - 09:16 UTC
This incident affected: Octopus Cloud.