Octopus Cloud Trial Signup - Service Disruption
Incident Report for Octopus Deploy
Resolved
This issue has now been resolved and all systems are working as expected
Posted Nov 20, 2024 - 07:12 UTC
Update
The cause of the issue has been identified and engineers are working on a fix
Posted Nov 20, 2024 - 06:53 UTC
Identified
The cause has been identified and engineers are working on a fix
Posted Nov 20, 2024 - 06:50 UTC
Investigating
We are currently experiencing an issue with Octopus Cloud Trial signups. New Trial instances are not being provisioned as expected.

Our team is actively investigating the root cause and working to resolve the issue as quickly as possible. We will provide updates here as soon as more information becomes available.

Users attempting to sign up for new Octopus Cloud Trials are unable to provision new trial instances at this time.
Posted Nov 20, 2024 - 04:55 UTC