Performance issues identified with Octopus Cloud

Incident Report for Octopus Deploy

Resolved

Azure have advised us this issue has been mitigated.
Octopus Cloud instances in the West Europe region were affected on 5 March from 6 AM to 5 PM UTC.
Azure will be providing us with a Root Cause Analysis, after which we can share more information.
Posted Mar 05, 2025 - 22:23 UTC

Update

We continue to see issues with our upstream to instances within the WestEU region. We are awaiting further information from Azure.
Posted Mar 05, 2025 - 16:17 UTC

Investigating

Octopus Deploy is aware of performance issues for some customers on Octopus Cloud. Our engineers are investigating and we will provide an update soon.
Posted Mar 05, 2025 - 14:17 UTC
This incident affected: Octopus Cloud.