OctoCLI and Tentacle RPM and APT package downloads
Incident Report for Octopus Deploy
Resolved
We identified that our package release process was affected by an upstream update earlier in the week. As a result, the release process was deleting, then failing to reinstate the public key on each deployment of our Linux packages. We have changed our package release automation so that it no longer fails to reinstate the public key, and have planned for future work to change the process so that it no longer touches the key at all.
Posted Aug 19, 2021 - 00:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2021 - 23:57 UTC
Investigating
We are aware that there are problems with our rpm and apt package keys and are working to resolve this. The problem may present as a 'Failure to retrieve GPG key' with error code 403
Posted Aug 18, 2021 - 23:43 UTC