Unable to create trial signups on Octopus.com
Incident Report for Octopus Deploy
Resolved
We've resolved this incident. Thank you for your patients.
Posted Jul 22, 2022 - 22:01 UTC
Investigating
We are investigating an issue that prevents new trial signups on Octopus.com. When completing the contact details portion of the signup form, users are redirected back to the form when clicking on the "Agree, start my trial" button.
Posted Jul 22, 2022 - 16:57 UTC
This incident affected: Octopus.com.