AWS authentication issue for customers using the "Run an AWS CLI Script" step

Incident Report for Octopus Deploy

Resolved

We are marking this issue as resolved. A fix has rolled out to customers.
Posted Jun 02, 2023 - 04:27 UTC

Monitoring

A fix is being deployed to our Cloud instances during their maintenance windows.

If you require the fix immediately, please contact support@octopus.com to arrange this.
Posted Jun 01, 2023 - 12:28 UTC

Identified

We have identified an issue with AWS credentials not being passed while using the AWS CLI Script step.

An issue has been raised and workaround is available, more details can be found here - https://github.com/OctopusDeploy/Issues/issues/8177

Please use the workaround until a patch is released.

Contact support@octopus.com with any questions and we'll be happy to help.
Posted May 31, 2023 - 12:29 UTC

Investigating

We are currently investigating an AWS authentication issue affecting Cloud customers using the "Run an AWS CLI Script" step
Posted May 31, 2023 - 11:49 UTC
This incident affected: Octopus Cloud.