Azure SQL connectivity issues in West US 2

Incident Report for Octopus Deploy

Resolved

This occurrence of the incident is considered resolved.
Further actions are being undertaken to prevent or mitigate future occurrences as detailed here: https://github.com/OctopusDeploy/Issues/issues/7843
Posted Oct 12, 2022 - 08:29 UTC

Monitoring

Azure has confirmed there was a Placement and Load Balancing (PLB) event at 6:28:17AM UTC. They are investigating what triggered this PLB event. In parallel, we are investigating ways to improve the resilience of Octopus Cloud in case of similar events in the future.
Posted Oct 11, 2022 - 06:52 UTC

Update

117 instances in the West US 2 region experienced this issue. We are continuing to assess whether this 80-second outage had any noticeable impact on Octopus Cloud functionality.
Posted Oct 11, 2022 - 02:04 UTC

Investigating

Some instances in the West US 2 region experienced a brief database connectivity issue from 6:28-6:29am UTC. We're investigating the impact.
Posted Oct 10, 2022 - 08:16 UTC
This incident affected: Octopus Cloud.