Octopus Cloud - intermittent deployment failures when using Git Credentials - MultipleActiveResultSets error
Incident Report for Octopus Deploy
Resolved
Octopus Cloud Customers have reported intermittent failures when deploying using Git Credentials. Deployments fail, showing an error message similar to "There is already an open DataReader associated with this connection which must be closed first. The connection does not support MultipleActiveResultSets".We have identified this problem was introduced by a recent code change, affecting Octopus Deploy versions 2024.3.2940 or higher. All known instances of this issue have been resolved.
Posted Jun 21, 2024 - 08:20 UTC
Identified
Customers have reported intermittent failures when deploying using Git Credentials. Deployments fail, showing an error message similar to "There is already an open DataReader associated with this connection which must be closed first. The connection does not support MultipleActiveResultSets".

We have identified this problem was introduced by a recent code change, affecting Octopus Deploy versions 2024.3.2940 or higher. Our engineering team is investigating further to determine a fix.

Potential Workaround: Retry the deployment. The problem is intermittent in nature.
Posted Jun 18, 2024 - 09:01 UTC