The fix has been released to Cloud - if you are still encountering issues, please ask the support team to upgrade your instance to 2025.1.3365
Posted Dec 11, 2024 - 00:08 UTC
Monitoring
The fix is now rolling out to Cloud. If this issue is affecting you, please reach out to the support team to ask them to upgrade your instance to the latest version.
Posted Dec 10, 2024 - 07:27 UTC
Update
We've identified the underlying code change that caused this issue to start appearing. We have a fix for it that will be rolling out to Cloud customers as quickly as possible. Self-hosted customers will not be affected.
Posted Dec 10, 2024 - 02:13 UTC
Update
We are continuing to actively work on resolving this issue. Our first potential mitigation didn't work as expected. We have a second potential mitigation that is performing better in testing. We will update here if/when we ship it.
Posted Dec 10, 2024 - 01:39 UTC
Identified
We are continuing to actively work on this issue. We have identified the issue and are testing a potential mitigation/fix. We are also continuing to investigate the underlying causes of the issue to build confidence our mitigation will work as expected.
Posted Dec 09, 2024 - 23:56 UTC
Investigating
Some Octopus Cloud customers are having intermittent issues with package acquisition steps throwing exceptions. We are currently investigating.