Intermittent service disruption for a small number of customers
Incident Report for Octopus Deploy
Resolved
Two seperate recent changes were identified as causes of the excess memory use. These changes have been rolled back, and we have confirmed through monitoring that memory use has returned to normal on the affected instances. No further crashes terminations have been observed.
Posted Feb 04, 2025 - 03:07 UTC
Investigating
Internal monitoring notified us that a small number of Octopus Cloud instances were terminated for excess memory use up to 12 hours after a recent a software upgrade. These instances were automatically restarted and resumed functioning correctly.

At this stage we are investigating to determine the cause of the excess memory use.

If you believe you are affected by this issue please contact support@octopus.com
Posted Jan 30, 2025 - 07:24 UTC
This incident affected: Octopus Cloud.