Octopus Cloud instances are currently down
Incident Report for Octopus Deploy
Resolved
All hosted instances have returned to normal operation.
Posted Oct 29, 2020 - 01:50 UTC
Identified
We have identified the root cause and are implementing a fix now.
Posted Oct 29, 2020 - 01:39 UTC
Investigating
Some customers instances are down. We are investigating the root cause.
Posted Oct 29, 2020 - 00:57 UTC
This incident affected: Octopus Cloud.