Docker Hub authentication issues

Incident Report for Octopus Deploy

Postmortem

Incident Summary

Docker Hub experienced authentication issues that prevented access to container images, resulting in deployment failures for projects relying on those images.

What We're Doing

Following this incident, we've identified several improvements to enhance service resilience and customer communication:

Visibility & Monitoring

  • Communicate third-party service outages more clearly on our status page
  • Explore in-app messaging to alert customers during service disruptions

Resilience & Good Practices

  • Review image retrieval reliability and address identified risks
  • Share good practices with customers to help reduce impacts when Docker Hub is unavailable
Posted Oct 09, 2025 - 03:39 UTC

Resolved

The Docker Hub incident is resolved and we have not observed any ongoing issues.
Posted Sep 25, 2025 - 04:18 UTC

Monitoring

Docker has implemented a fix and we are monitoring.
Posted Sep 25, 2025 - 01:23 UTC

Identified

Docker Hub is experiencing an active incident: https://www.dockerstatus.com/pages/incident/533c6539221ae15e3f000031/68d47a2f93c09e05486d93a9

Octopus customers may experience issues pulling images from Docker Hub, including:
1. Octopus Server self-host images
2. Deployment process container images including execution containers and reference packages hosted by Docker

Workarounds are available, please contact support@octopus.com.
Posted Sep 25, 2025 - 01:06 UTC
This incident affected: Octopus.com and Octopus Cloud.