Cloud instances unable to communicate with listening and polling tentacles
Incident Report for Octopus Deploy
Resolved
All Octopus Cloud customers have been upgraded to fixed software versions, resolving this incident.

Self-hosted customers were not affected.
Posted Dec 13, 2023 - 02:45 UTC
Update
We have identified customers that were most likely affected. and prioritized applying the fix to these customers on the 9th and 10th of December. Rollout continues to all remaining customers, and we anticipate this to be complete by the 12th of December.
Posted Dec 11, 2023 - 01:31 UTC
Monitoring
A fix has been created and is being rolled out to affected customers.

This issue affects instances of Tentacle that use SHA1 (an old, unsupported, encryption algorithm), and prevents them from connecting to Octopus Cloud. This was a side effect of the Octopus Server .NET 8 upgrade, and the resulting change to the underlying OS from Debian 11/OpenSSL 1.x to Debian 12/OpenSSL 3.x.

If you continue to be affected by this issue, please try the workaround detailed at https://github.com/OctopusDeploy/Issues/issues/8523, or contact support at https://octopus.com/support.
Posted Dec 08, 2023 - 10:21 UTC
Identified
The underlying cause has been identified. The issue is currently isolated to cloud customers. A fix is actively being work on.
Posted Dec 08, 2023 - 06:06 UTC
Update
We have identified a suspected root cause and workaround.

We suspect this is limited to certificates using a SHA1 algorithm but are investigating further.

If affected please try the workaround detailed in this issue: https://github.com/OctopusDeploy/Issues/issues/8523
Posted Dec 08, 2023 - 03:41 UTC
Investigating
Since the morning of Friday 8th December, cloud customers are reporting issues with communicating to listening and polling tentacles. We are investigating this as a priority incident and will work on a resolution as soon as possible.
Posted Dec 08, 2023 - 01:23 UTC
This incident affected: Octopus Cloud.