Cloud instances may be missing task log lines or show incorrect status for deployment steps
Incident Report for Octopus Deploy
Resolved
This issue has been resolved and we have not seen any further errors.
Posted Dec 20, 2023 - 03:54 UTC
Monitoring
A fix has been implemented on all Octopus Cloud instances and we are monitoring for any further errors.
Posted Dec 15, 2023 - 03:42 UTC
Update
We are currently rolling out a fix for this issue.

We will provide an update once all Octopus Cloud instances have the fix applied.
Posted Dec 12, 2023 - 06:41 UTC
Identified
We have identified the cause of the issue and are testing mitigations.

We are working on this issue as a priority.
Posted Dec 11, 2023 - 00:26 UTC
Update
We have identified a workaround. The issue occurs when a deployment's task log is viewed while the deployment is running. If users navigate away from viewing a running deployment, all task log lines should be successfully saved. This will also avoid the issue where deployment steps may show the wrong status.

We are working with our upstream provider to resolve this issue.
Posted Dec 07, 2023 - 01:17 UTC
Investigating
We have identified an issue where some Octopus Cloud instances since 20 November 2023 are missing some log lines from their task logs.

Deployment steps that encounter this problem could also show the wrong status (e.g. showing as still running) even though the step has completed successfully. The deployment task will have the correct status.

We are investigating this issue as a priority.
Posted Dec 06, 2023 - 06:20 UTC
This incident affected: Octopus Cloud.