gRPC port (8443) shows Octopus Cloud instance is Undergoing Maintenance

Incident Report for Octopus Deploy

Resolved

This incident has been resolved. Please don't hesitate to reach out to our support team if you are still having any related problems.
Posted Mar 25, 2026 - 06:09 UTC

Monitoring

We have a resolution for the issue, and it should be rolled out to customer instances during their next maintenance windows. If this blocks your deployments in the meantime, please reach out to support.
Posted Mar 24, 2026 - 05:58 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 24, 2026 - 04:13 UTC

Investigating

We have identified the cause and are working to complete it as quickly as possible. We will provide another update once the issue is resolved.
Posted Mar 24, 2026 - 04:13 UTC
This incident affected: Octopus Cloud.