AWS deployments failing when using service role for EC2 instance
Incident Report for Octopus Deploy
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 05:03 UTC
Monitoring
We have implemented a fix in v2024.1.6809 which will be rolling out to cloud customers over the next two days. If you need the fix in your cloud instance sooner, please contact https://octopus.com/support. We will continue to monitor for any further issues.
Posted Jan 09, 2024 - 04:03 UTC
Identified
We have found a likely cause of this issue and are working on a fix. In the meantime, please refer to the Github issue for more updates - https://github.com/OctopusDeploy/Issues/issues/8551
Posted Jan 08, 2024 - 22:44 UTC
Investigating
We're investigating AWS deployment failures for customers upgraded to 2024.1.6245 and are using the "AWS service role for an EC2 instance" option, which throw the error "An account identifier was not found".

For more details of the issue and a possible workaround see the Github issue https://github.com/OctopusDeploy/Issues/issues/8551
Posted Jan 08, 2024 - 21:22 UTC