GitHub upstream outage causing issues with VCS-backed elements

Incident Report for Octopus Deploy

Resolved

We have observed no further errors stemming from this issue.
Posted Nov 19, 2025 - 00:47 UTC

Monitoring

GitHub reports that git operations have been restored. We will continue to monitor this situation.
Posted Nov 18, 2025 - 22:01 UTC

Identified

GitHub is experiencing issue with git operations, resulting in in-product git operations to be degraded or fail. We're continuing to monitor this upstream outage.
Posted Nov 18, 2025 - 21:11 UTC