Manual intervention steps on Configuration-as-code projects may throw errors
Incident Report for Octopus Deploy
Resolved
This incident has been resolved. A public incident report will be made available to affected customers. If you would like a copy, please get in touch with us at support@octopus.com.
Posted Nov 17, 2023 - 03:22 UTC
Monitoring
We are now in the process of rolling out a version containing a fix to resolve the issue. This will be available to affected customers and we will be monitoring for any further issues.
Posted Nov 14, 2023 - 03:52 UTC
Identified
We have identified the root cause of this issue and are working on a hotfix build.
Posted Nov 13, 2023 - 20:29 UTC
Investigating
We are investigating reports of Octopus Cloud users on 2024.1.746 having issues in the follow scenario:
* Configuration-as-code projects with a Manual Intervention step, with the "Responsible team" set to a System-level team.

More details including a possible workaround can be found in the following GitHub issue: https://github.com/OctopusDeploy/Issues/issues/8473
Posted Nov 13, 2023 - 19:32 UTC