(Resolved) Some Deployments/Runbooks in Octopus Cloud may be failing to start

Incident Report for Octopus Deploy

Resolved

This issue is resolved, please reach out to https://octopus.com/support if you are still experiencing deployments that fail to start.
Posted Sep 05, 2025 - 03:50 UTC

Monitoring

Symptom: The Deployment or Runbook appears to have started but has not produced any logs after an extended period of time.

Mitigation: Manually cancel the Deployment or Runbook, then re-run the task. Please note that cancellation may take approximately 10 minutes.

After the next maintenance window all affected tasks will be automatically cancelled.

Please reach out to https://octopus.com/support if you would like tasks to be automatically cancelled earlier.
Posted Sep 04, 2025 - 02:31 UTC
This incident affected: Octopus Cloud.