Octopus ID and a subset of Octopus.com URLS unavailable

Incident Report for Octopus Deploy

Resolved

Services have been operational and stable since recovery 6 days ago. The incident was caused by an abnormally high frequency of requests, resulting in degraded service. We have relieved the bottleneck and are investigating why the compensating controls we had in place didn't compensate as expected.
Posted Sep 03, 2024 - 04:55 UTC

Monitoring

Services are currently operational. Our team is continuing to investigate the root cause.
Posted Aug 27, 2024 - 14:07 UTC

Investigating

Users are reporting 502 and 504 timeouts when attempting to log into their Octopus.com accounts, limiting access to Octopus Cloud and Control Center.

A small subset of Octopus.com URLs are also impacted:
Octopus.com/blog
Octopus.com/start
Posted Aug 27, 2024 - 13:30 UTC
This incident affected: Octopus.com / OctopusId, Octopus Cloud, and Control Center (billing.octopus.com).