Ability to deploy in West US 2 might be affected

Incident Report for Octopus Deploy

Resolved

Our upstream provider, Azure in West US2, has resolved their issue. While the issue was ongoing, some Octopus Cloud instances in West US2 may have experienced brief downtime and network communication issues. For more details, see Azure's incident report (Tracking ID: GHRP-84G) at https://azure.status.microsoft/en-us/status/history/.
Posted May 30, 2026 - 00:38 UTC

Monitoring

Our upstream provider, Azure in West US2, is currently experiencing an issue which might be affecting your ability to deploy.

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted May 29, 2026 - 06:10 UTC
This incident affected: Octopus Cloud.