New signups to Octopus Cloud are unavailable
Incident Report for Octopus Deploy
Resolved
Signups are available again. We are sorry for any inconvenience.
Posted Feb 15, 2024 - 05:43 UTC
Investigating
We have identified an issue preventing new signups from completing. Engineers are currently investigating.
Posted Feb 15, 2024 - 05:26 UTC
This incident affected: Octopus Cloud.