Self-hosted customers experiencing high CPU usage after upgrading to 2023.4.8xxx
Incident Report for Octopus Deploy
Resolved
This issue was resolved in 2023.4.8166.
Posted Jan 24, 2024 - 03:46 UTC
Monitoring
With the release of 2023.4.8166, we believe we have addressed the memory and CPU usage spikes associated with the variables endpoints. We continue to monitor to ensure these endpoints operate smoothly. For more details see this GitHub issue: https://github.com/OctopusDeploy/Issues/issues/8529
Posted Dec 20, 2023 - 00:25 UTC
Update
We have implemented a fix in v2023.4.8166. Should you encounter any issues after upgrading, please do not hesitate to reach out to our support team.
Posted Dec 15, 2023 - 07:48 UTC
Update
We are actively continuing our investigation into the reported issue. Thank you for your ongoing patience as we work towards a resolution.
Posted Dec 13, 2023 - 07:12 UTC
Investigating
We are currently investigating this issue that has been reported, as a high priority.
Posted Dec 12, 2023 - 23:57 UTC