Dynamic Worker Leases failing in WestEU
Incident Report for Octopus Deploy
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 01:53 UTC
Update
Dynamic Workers are now provisioning successfully. We are continuing to monitor for any degradation of service.
Posted Feb 27, 2024 - 01:16 UTC
Monitoring
Dynamic Workers are now provisioning successfully. We are continuing to monitor for any degradation of service.
Posted Feb 26, 2024 - 22:37 UTC
Update
Dynamic Workers are now provisioning successfully. We are continuing to monitor for any degradation of service.
Posted Feb 26, 2024 - 22:36 UTC
Update
We continue to work with Azure to investigate the issue.
We are also investigating a potential workaround.
Another update will be provided within the next hour.
Posted Feb 26, 2024 - 22:09 UTC
Investigating
Our upstream provider, Microsoft Azure, is currently experiencing an issue which is affecting our ability to provision worker virtual machines for a subset of customers in WestEU. We are working with Azure to resolve the issue.

If you experience this problem, deployments utilising dynamic workers will fail with an error specifying that Octopus Deploy could not obtain a dynamic worker lease.

We will provide an update in an hour, at approximately 20:00 UTC.

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted Feb 26, 2024 - 19:07 UTC
This incident affected: Octopus Cloud.