Emails are currently not being delivered

Incident Report for Octopus Deploy

Resolved

Email services have now been restored. Please contact support@octopus.com if you encounter any issues with email delivery.
Posted Feb 26, 2026 - 05:47 UTC

Update

Sign-in/sign-up emails have been restored. Note: emails will now be sent from donotreply@octopus.com
Posted Feb 26, 2026 - 05:32 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 26, 2026 - 05:11 UTC

Identified

Our upstream email provider is currently experiencing issues delivering emails from Octopus. This impacts all emails, including email verification during authentication, Octopus Cloud subscription invitations, and billing notifications.

We're currently investigating and will update this page when we know more.
Posted Feb 26, 2026 - 01:51 UTC
This incident affected: Octopus Cloud, Control Center (billing.octopus.com), and Sign-in/Sign-up (octopus.com).