Task failures - The database has reached its size quota
Incident Report for Octopus Deploy
Resolved
This incident has been resolved.
Posted Jan 24, 2022 - 01:55 UTC
Identified
We have currently identified an issue with task failures involving the following exception message, "The database has reached its size quota":

```
| Failed: Unable to mark task as complete, will continue to retry
Warning | Error while executing SQL command in transaction 'RelationalTaskRunner.TaskComplete': The database has reached its size quota. Partition or delete data, drop indexes, or consult the documentation for possible resolutions.
```

We have identified the problem and have a fix prepared, which will roll out to Cloud instances next week during outage windows.

If your instance is affected, please contact support.
Posted Dec 10, 2021 - 04:55 UTC
This incident affected: Octopus Cloud.