Step variable substitution not running for Azure steps and steps based on templates
Incident Report for Octopus Deploy
Resolved
The Octopus Cloud rollout has completed. This incident has been resolved.
Posted Oct 01, 2020 - 01:05 UTC
Update
UPDATE

We've started rolling out a patch with the fix (2020.4.2) to Octopus Cloud. The rollout should complete in around 24 hours.
Posted Sep 29, 2020 - 03:49 UTC
Update
UPDATE
We have identified that steps created from step templates that have "Substitute Variables in Templates" or "Structured Configuration Variables" enabled may also be affected if the step was created on a version of 2020.3 that is earlier than 2020.3.1.

WORKAROUNDS
For steps based on step templates, recreating the step from the template will resolve the issue.
Posted Sep 25, 2020 - 01:16 UTC
Identified
UPDATE

Affected steps are:
- Run an Azure Script
- Deploy an Azure Web App
- Deploy a Service Fabric App
- Run a Service Fabric SDK PowerShell Script
- Deploy an Azure Cloud Service

Affected step features are:
- Substitute Variables in Templates
- Structured Configuration Variables
- .NET Configuration Variables

The issue where the feature doesn't run only only occurs if you have edited the step recently.

WORKAROUNDS

Substitute Variables in Templates:
- Add a variable to your project named: "Octopus.Action.SubstituteInFiles.Enabled" and set the value to "True".

Structured Configuration Variables:
- Add a variable to your project named "Octopus.Action.Package.JsonConfigurationVariablesEnabled" and set the value to "True".

.NET Configuration Variables
- Add a variable to your project named "Octopus.Action.Package.AutomaticallyUpdateAppSettingsAndConnectionStrings" and set the value to "True".
Posted Sep 24, 2020 - 01:23 UTC
Investigating
We are currently aware that the "Substitute Variables in Templates" feature is not running for Terraform and Azure steps (other step features might also be affected). We are working to fix this issue as quickly as possible.
Posted Sep 23, 2020 - 23:21 UTC
This incident affected: Octopus Cloud.