A small number of Octopus Cloud instances are down.
Incident Report for Octopus Deploy
Resolved
This issue has been resolved
Posted Sep 29, 2020 - 04:07 UTC
Update
Instances that were previously down have been corrected.

Deactivated instances are not able to be reactivated.
Ubuntu workers are unavailable.
Posted Sep 28, 2020 - 23:05 UTC
Identified
Due to an incident in a down-stream provider, a small number of Octopus Cloud instances are offline
Posted Sep 28, 2020 - 22:27 UTC
This incident affected: Octopus Cloud.